Iceni Technology Forum

Can't export pages -- "failed to connect to the open and save panel service"

Hi,
I have just marked up all the tables in a 60 page PDF with a view to exporting them. When I do “Export … Pages As”, I get this message.

The save file operation failed.
The save file operation failed to connect to the open and save panel service.

I’m running Infix 7.6.9 (latest version) on Mac OS 12.2 (Monterey).

I have written about this problem before but have not received a reply.

Thanks in advance.
John

Hi.
After reading your post, I tried Infix on my own Mac running Monteray 12.3.1.
First I tried Infix 7.6.8 then 7.6.9. I marked-up a small PDF, then chose File→Export→Pages As… and selected a folder on my desktop. In both cases, it worked correctly.

The Mac I was using is an M1 system. Is yours an Intel or M1 system?

It’s an Intel MacBook Pro. We have also tried on an old iMac running Catalina 10.5.7. Same message, both with latest version and with a version a few decimals behind.
We have been having this problem since at least January 2021. I have 2 e-mails I sent to support@iceni.com dated 28 Jan 2021 (Infix 7.5.2 and the previous MacOS, if I remember correctly) and 14 Sept 2021.
I see this “open and save panel service” issue appears on lots of support forums in connection with everything from Microsoft Word to Python.
Hope you can find a solution.
Thanks,
John

I can let you have our PDF file to see if it’s a problem with the PDF. If you could send us back the exported pages file, that would be amazing :slight_smile:
John

Hi.
We have an Intel Mac running Catalina 10.15.7 and do not have an issue with the current version or previous versions of Infix.

I wonder if there is some issue with the installation of Infix on your machines or maybe some other software which is, in some way, clashing.

I will see what I can find out about the “open and save panel service” issue you mention. In the meantime, have you completely removed Infix and tried re-installing? This is not a straight forward task, but the instructions to do so can be found at: Infix FAQ | Iceni Technology Products

It may also be worth checking-out the PDF you are trying to process - thanks. You can email that to support@iceni.com

Guy

Looking around, it appears the problem may be related to the file extension being used for the save operation; possibly a MacOS bug.

  • Do you get the problem whenever you try to save a PDF or only when you try to do the ‘Export Pages As…’?
  • Does it depend upon which file-format you export?
  • Does it depend on where you choose to save - the folder or drive?

Hi Guy,
It gets stranger. I did a clean install.
Trying to export pages as Microsoft Word, RTF or HTML as a SINGLE DOCUMENT gives me the same error.
However, if I choose “separate document for each page”, it performs perfectly.
John

  1. Save as PDF with new name ----> no problem
  2. Export Articles as Microsoft Word ----> no problem
  3. Export Pages – where I can choose “Create file for every page/article”, this works. However, where I choose to export as a single file —> problem (Plain text, HTML, EPUB, RTF, Microsoft Word).
    When exporting pages, I choose not to export graphics, just text.

Hi.
I am able to export all the formats you cannot. I wonder how our systems differ.
I am running MacOSX 10.15.7, Infix 7.6.9.
I also tried it on an older mac running Sierra 10.12.6 - again with no issues.
And using an M1 mac running Monteray 12.4 - again without issue.
Do you have any other computers you could try?

Hi,
We managed to export Pages using Infix under Windows. I may be able to test it on another Mac, but I don’t know what conclusions we might be able to draw.
John