copy and paste discard font type

Hi, again !

I wish to copy and paste tex into a pdf from a word doc but I want to use the font and size that is already in use in the pdf not what is in use on the doc file. Is there a way that when I copy and paste info into a pdf I keep the font that is in use in the pdf ?

Hello - yes there is way to paste, ignoring using the font in the PDF, not the font of the text on the clipboard.
Instead of choosing Edit->Paste, position the caret where you need to paste and choose Edit->Paste As Plain Text.
Whatever font is active at the insertion point, will be used for the text being pasted.

Thank you !!!

Is there a quicker way to do this ?? I have lots of tex in different pdf’s that need editing. In earlier versions this wasn’t the case, I may have to go back to the older version

Are you hoping just to use a keyboard short-cut instead of the menu “Edit->Past as plain text”? There isn’t a short-cut at the moment (we didn’t think people would use the feature much!). However, we will add one for the next maintenance release due in a few weeks.


Yes in the older version’s when you copied and pasted tex into the PDF the font in use (in the PDF) would be used. I dont see why anyone would be coping tex into a pdf and wishing to change the font type at the same time. Please can you roll it back to earlier versions.

We had many requests from customers who were used to copying styled text from a Word document or some other application and wanted to retain the styling when pasted into their PDFs.


I would agree that the option of retaining styled text from a word document should be available, but not the default option. If your editing a PDF chances are you want to edit in the font used in the PDF.

When I try to insert a change, sometimes the text font I type doesn’t match the font on the PDF. For example, I changed “mid-west” to “Midwest” by deleting hyphen and deleting “m” and changing it to cap “M.” The word comes out Midwest. (I am using angle brackets to signify the font.) Am I doing something wrong, or is this a glitch? Thank you.

If the characters that you are trying to insert are not available in a font contained within a pdf file because it is an embedded subset of the font and there is no full version of the font available on your computer, Infix 6.26 will currently default to Arial. This is why sometimes Infix 6.26 is using Arial. It shouldn’t do this, as when a character used in a font is not available in the pdf or from the “Fonts” directory on your computer, Infix should show a dialog that asks you to choose an alternative font to use. This issue has been fixed for the release of Infix 6.27.

Well, thank you, Martin the Moderator! Your reply makes sense. In the meantime, my somewhat arduous fix is to find in the already-finished PDF the letters I want, and then I copy and paste them. A little faster than hot-letter press by hand or using a medieval monk! :wink: Also, I will see if I can load the missing font onto my computer, and I’ll look forward to the update of Infix 6.27.

I am trying to replace fonts in a large “joined”.

I am told by the document | font menu that Verdana, BOld exists in 700+ places.

I select all objects and Find | Replace “font” Verdana, Bold with Arial Bold and the response is:

“Replaced 0 occurrences”

When I search for font “Verdana, Bold” I get “The specified text was not found”

Yet when I look in Document | Fonts I can see that Verdana, Bold is still there

What does this mean?

Could you please send to PDF to us at and we will investigate further.

Thanks, Simon.


Sorry about the delay.

I would like to attach the document with the Verdana,Bold font I want to replace with Arial Bold.

How do I send it in this forum?

Please email it as an attachment to us at

Thanks, Simon